Add support for Dual CAN adapter

Please add support for the new Dual CAN adapter, here’s the VID and PID.

This is a USB CDC device, is it possible to show both CDC interfaces? and maybe give them different names? I do this on Linux with this script below, can we make Realdash detect both interfaces ?


Will be in next release. Dual needs to have either different names or different serial number, otherwise there is no way to know into which one to connect.

Thanks for that. They can’t have different serial number or names (to my knowledge). On Linux I can know which one to connect using “bInterfaceNumber”, it’s either “00” or “02” not sure if you get the same attributes on Android?

I’ll send you a unit next week so you can try it out. :smiley:

2.2.1 has support for VID 16D0 PID 11FD as CDCACM driver.

Keep the hardware coming :smiley:

I finally tried the dual channel CAN adapter from MeatPi. Adapter seems very fast and reliable in receiving CAN frames, but unfortunately it does not send any frames to CAN bus. Could you check on your end what could be the reason for this?

Tried with RealDash firmware, dated 4.4.2023

Thanks! I fixed the issue, try the latest version “dual_can_realdash_fw_v120.bin”. Please let me know if it works as expected.

The issue was that realdash sends frames using “CAN 44 frame” protocol, my adapter only supports “CAN 66”. Now I’ve added support for “CAN 44”.

Just tested the latest firmware and it is not yet working. When sending a CAN frame from RealDash, I can see that receiving device gets the frame with correct id, but data length is 0 and there is no data bytes received.

I will make a new feature to RealDash CAN Monitor to allow sending CAN frames directly from there to make testing easier.

I found the problem. And I successfully tested in Realdash, I’ve added a button that sends a CAN frame. Update to “dual_can_realdash_fw_v130”

Works perfect now :thumbs:

Please check if there is a similar issue with other devices as we have received couple of reports CAN frame sending not working on your adappters.

Thanks for testing! I confirm this issue is resolved on all adapters.

1 Like