Add time delay between different actions

Hi! You can notice from screenshot attached that my cluster displays session distance and average fuel consumption simultaneously. However, I would like it to work the other way. Namely, I want it to show session distance for 5 seconds, then it hides session distance and displays average fuel consumption for 5 seconds and it hides fuel consumption and shows session distance for 5 seconds again and so on. The problem is I still can’t figure out how to add this 5 seconds delay. Is it possible to do so on iOS device? Or at least using some xml coding? Or currently RealDash doesn’t support this feature?


There are special inputs called ‘Dummy Timers’. Timers are always running, and you can use the trigger-action system to reset the timer and run a specific action when timer gets over say 5 seconds. Give it a try.

It worked, thank you a lot!!!
For anyone wondering how to do it: you need to create three triggers:

  1. once dummy timer is greater or equal 0 AND less than 5 — hide gauge 2 and show gauge 1;
  2. once dummy timer is greater or equal 5 AND less than 10 — hide gauge 1 and show gauge 2;
  3. once dummy timer is greater or equal 10 — set value of dummy timer to 0.

I used this lovely feature to jump from Page 1 to 2 to 3 and back after specific time intervals. However, since this dummy timer is always running, I am not able to edit the dashboard in edit mode. How to overcome this without deleting the trigger and action?

I have a suggestion, it would be useful to have an enable/disable option for every trigger so that we can temporarily disable a trigger if it doesn’t work to your liking.

Would appreciate a work around for the above problem.

How about if I just disable the Dash page change action when in edit mode? I don’t see any reason why would anybody want to switch dash page with triggers when editing.

I will see if we can do something about enable/disable triggers.

When in edit mode, I guess all triggers and actions can be disabled at the backend. For example, I want to move the position of a gauge or change some input value. I am not able to choose any item on the dashboard when this trigger is running and keeps switching pages.

Will I have to wait for next release? No other workaround for now?

Thanks in advance.

Edit: Temporary workaround: Adding some cooldown secs to the trigger allowed me to edit. You may consider enable/disable triggers like they have in macrodroid and other automation apps.

I hope publishing the next beta tomorrow, which has page switch actions disabled when in edit mode.

Great, thanks. I purchased the full version today and also signed up for beta just now.

Is there a way to reduce the speed with which it picks up voice commands? By the time I say the destination it stops listening.

Also it is not taking my current location when I press that icon near From. Should I keep internal gps on? Tried on and off but facing same issue.

I have the default dashboard. The map gauge on the right is not showing current location. When voice command is on how to switch views from map to music gauge? When I tap the screen it starts listening for voice command.

Can I map a button to listen to voice command?

Yes, GPS has to be on for navigation. Speech recognition stop is automatic by API to stop when it no longer detects any sound.

You can make a button and attach an action to start voice recognition.

There should be a way to stop touching screen to activate voice command when button is set, else button is of no use.

Anyway, thanks for the beta version.

Quick feedback:

  • I was able to disable some triggers. But after a while the app started hanging and I couldn’t find some of my triggers. Fortunately, I had a backup xml and was able to revert.

  • Page is not switching while in edit mode, which is good.

Is there a way to go back to stable after updating to beta?

Another general point…auto fill is populating jumbled characters when I choose them from google keyboard. Also there should be a way to go to specific location in a phrase to edit rather hit backspace and type the whole phrase.

Ok, thanks for the feedback. I will check the logs from Play store if there is an indication of a hangs. If you find out how to re-produce the problem, let me know.

I found the hang and fixed to 1.8.8 beta 2. The hang was related to disabled triggers not loading correctly if they had more than one condition set into them.

Thanks, seems to be ok now. Will test tomorrow and get back of any issues.