Android and CANable connection problems

Hi,

I started to write about problems with the canable can-to-usb adapter and android phone. Turns out that the specific adater had PCAN emulation firmware on it and thats why it didn’t work. Got firmware flashed to slcan finally and got it working at windows realdash. Some reason the slcan firmware does not work with linux/savvycan and therefore with the android phone. Have someone been dealing with the same problem?

-Sipi

Below is the orginal text that is about to post before I figured the firmware problem:

I have a aliexpress CANable copy can-to-usb adapter that I’m trying to use with android phone (samsung S24) . I have tried to send and receive can bus data in pc(savvycan at linux) with two CANables and it seems to be working correctly. I’m playing data recorded from the car with one adapter and receving it with the other. When I plug the adaptger to phone and try read the bus data with realdash I cannot receive it. Could it be thaht somehow the phone cannot acces to the adapter.
Description of current status:
- added the adapter as CAN/LIN device → SLCAN->SERIAL/USB->
- Phone finds the device: XCAN-USB
- tried all the baud rates 115200, 1228800, 2000000
- not touched the advanced settings
-can settings:

  • can frame:standard*
  • can speed: 500 kbps*
  • can mode: normal*
    - adapter red and blue leds are blinking constantly

Link to the adapter https://www.aliexpress.com/item/1005005963727624.html

BUT the can monitor shows nothing.
Any advices how to proceed?