Android USB-Serial Device

I have successfully interfaced a Subaru SSM based ECU to RealDash using an Arduino as the interface communicating on RealCan protocol. For all of my testing I communicated from an iPad Pro over Bluetooth (HM-10). For my final install in the car, I would like to use an Android 9 device and a hardwired connection. I am looking for recommendations on a USB OTG to Serial interface that works with Android 9 if anyone has used one that they know works well.


Currently all USB-Serial converters that I have tested have worked except for one very old Profilic chipset converter which causes problems on Windows. Maybe because of that I prefer FTDI chipset converters. Never had any problems with them.

I currently have this device, which appears to be the most common on the market:

When connected to my tablet and open the manufacturer app, I can see data flowing from the arduino to the tablet, see screenshot:
But when I open the RealDash app and try to add a serial device, it never finds the device. Even after 20 minutes it still on this screen:
Any suggestions? I have Developer mode turned on, I have USB Debugging enabled, and I have the device set to file transfer in settings.


I was able to borrow a Prolific 2303 Adapter from a co-worker, it’s not labeled as made for Android like the FTDI is, but the tablet recognized it instantly, and so did real dash. So now real dash can see my USB-Serial adapter, but something is still amiss.

When I try to view the Can Monitor, it simply says “connecting” and then never shows any data. It never times out (unless I unplug the cable), but it never shows data. I can see the data coming in using a terminal application on the tablet.

I have tried 4800, 9600, and 115200 for baud rates with no luck. This is the same code that worked perfectly via an HM-10, just moved the wires from the bluetooth adapter to a DB-9 adapter and plugged in the Prolific cable.

Any other suggestions?

Please see this post:

“Please be considerate with your requests. Do not ask us to troubleshoot custom hardware/software setups as it would require us to build the same setup for testing and we just do not have resources to do that. We cannot make speculative fixes based on a hunch of what might be wrong.”

I apologize for not stating my request more clearly, I am not looking for anyone here to solve my problem, just help me to understand the software tools built in to help me solve it myself.

For example, I see there is a serial debugging option, but I was unable to find where RealDash stores the file on the android OS. I tried the “send to developers” button hoping it would open up email and I could save the attachment, but it apparently just sends in the background. I believe if I could look at this file I might understand what the software is reading and why it is not registering the packets.

Any other tips on how to use the software features to help me solve my own problem would be appreciated.

If anyone else comes across this, I arrived at the solution via a roundabout method.

The core of the issue is that RealDash was not getting legitimate data from the Arduino. The serial cables I utilized were RS232 cables designed to talk to devices that used -24V/+24V to communicate 0 and 1. When talking to an arduino (and many other microprocessors) you need a device that is specifically designed to talk “TTL”, which is where the 0/1 is 0V/5V instead of -24/+24. Tossing the FT232 and Prolific2303 and buying this device here has solved the problem.


Happy to hear you got the problem solved. As there are literally hundreds of different serial adapters it is just plain impossible for us to try them all.

The serial debug log is not available for viewing as it may contain information that is under NDA between us and some aftermarket ECU manufacturers. ‘Send to developers’ option uploads the file to our server.

I really wonder if the problem you had is not realizing the Arduino has a built in ftdi ttl to usb? I just plugged the arduino directly to my tablet and it worked. This post is old. I am not aware of any Arduino that had an RS232 port. The can shield has a rs232(db9). But that is for CAN and not Serial.

Anyways figured i’d say, I do not believe it’s needed to use an adapter because most Arduino boards have one built on the stock board. If your going to use Serial1 or Serial2 on some boards then it might be necessary to use external adapter.

I wished to retain the built in TTL on Serial 0 for the laptop communications, troubleshooting, and loading new code and have a dedicated port for the Android. Thus the need for an adapter.