can.xml version2

right now I change my can.xml to version “2” and Realash stop working.
I change


Whats wrong??
realdash_can_example_mod6.xml (10 KB)

For me, the file loads ok with 62 input values. Obviously I cannot test it with live data, but syntax of the file is correct.

Thank you,
but Realdash stop working with the

My data come from Arduino, do I have to change here something??
Sometimes it is working, after changing the xml forth and back, and then it stop.
Other idea? I going crazy…

Sorry to hear that. But file itself seems ok. That’s how far I can help with custom hardware.

I still try to figure out, what is the problem…
it seems, the XML file is OK (as you say), the demo Arduino test Dash is working with this file, also with my Arduino!
So I think, it is my dash file!

If I select for a gauge “input&values” → select input → ECU SPECIFIC, I see alot same inputs (for example: “Arduino Example Digital 1”)
Is it possible, to clean it up, to have only the input values from the actual xml file?
I think, here is maybe the error located.

Furthermore: When the dash loading with the can.xml version2, the dash stuck after the swipe with all gauges switched on.

Today I test the setup with Realdash Windows (version 1.8.7)…
working!!! :open_mouth: :confused:
So you have a bug in the Android version (version 1.8.7)

You can clean up the Ecu Specific inputs from ‘Settings->Units & Values->Imported Values’. Select them all and use the item burger menu to delete them.

funny… as I reset the imported values, it is working 1x…
after some time the same error.
There is a bug in the Android version.

I have trouble understanding you. In same sentence you say “its working” and “there is a bug”. Please be more precise. What is working? What is not? On what platform? (Note that RD CAN XML parsing is 100% platform independent operation).

I reset the inputs as you mentioned:
“You can clean up the Ecu Specific inputs from ‘Settings->Units & Values->Imported Values’. Select them all and use the item burger menu to delete them.”
(with the .XML file that was making my dash hang at ANDROID device.)

Result: The Dash work.
But: After changing one input value, Dash stop working again.
With the Windows REALDASH everything working as expected.

Have you tried to re-import the XML file on Android every time you make a edit? Especially if you keep your file on network drive, RealDash does not have access to network resource and uses a locally cached copy of that file.

sometimes I reimport, yes!
But from the local Android memory.

Please attach the XML file that is causing a hang in Android.

Here it is the file…
realdash_can_example_mod6.xml (10.1 KB)

I tried your XML file on Windows, Android and even on iOS. No hangs whatsoever when XML file is loaded. Naturally I’m unable to test the actual data that is described in XML file as I do not have a device that would send the data.

Sorry that you are experiencing problems. I’m afraid this is as much as I can do for this :frowning:


What is the different between xml version 1 & 2 ?


I can’t even remember anymore. v1 is so old that I’m not sure if it even works anymore (loader is still in RD though).