Connection to Megasquirt

New user here. I’m trying to see if I can get RealDash to work with my Megasquirt based controller before I buy the full version and spend a lot of time making custom dashboards for my Galaxy Tab A. I have Real Dash installed on my Win10 PC and also the tablet. My logic is to do all the the design work on the PC then transfer the files to the tablet for actual use in the vehicle. The first step would be to see if I can get RealDash and my controller to talk to each other. My controller uses a custom .ini file based on MS2Extra comms342h2 and it works well with Tuner Studio and Shadow Dash. I am using the default dashboard in RD for the time being. I have the data source set up as Megasquirt serial/USB 115200 baud. I have imported my current .ini file and it shows up in RD as Maincontroller.ini.
I have my controller set up on the bench connected to a simulator but when I connect it via Serial/USB to my PC with RD running, nothing happens. What am I doing wrong?

You can try first without ini file to confirm the connection with default Megasquirt output. If that works, then there is something in the ini that RealDash fails to load.

Thanks for the quick response. I went back to connections and un selected the my .ini file . Then I enabled debug logging. I powered up my controller and plugged the serial cable from the controller with the serial/USB adapter that I always use and plugged it into my PC with RD running. I left it for a couple of minutes. Nothing happened and the debug file size is just 1KB, the same as when it first comes on. I suspect I’m forgetting to set something, but I don’t know what.

I assume you are using some sort of Serial to USB adapter. What brand/model is it?

No idea, no markings on it. It works just fine with Tuner Studio and Shadow Dash.

On Device manager it just shows up with the manufacturer as FTDI.

I had another thought. When I say that my controller can connect with Tuner Studio and Shadow dash, it is on my Win7 Pro laptop, which is what I have been using for development. I just tried to connect to Tuner Studio with the same cable on my PC which is running Win 10 and no go. I am not comfortable with all of this and only know barely enough to develop my controller the way I want it to work. Integrating with Tuner Studio and Shadow Dash has been a real struggle, but I am an armature and these things are to be expected.
Another thing is when you asked about serial. USB adapters, I have another one that I bought when I bought the tablet a couple of years ago, but I had no success getting it to work with anything ,so I assumed either it was me or it was DOA . It’s a plugable serial USB adapter for Model PL2303-DB9 for Win 10,8.1,7, XP. That might be another clue.

Another clue. I tried using my plugable USB serial adapter again on my Win7 Pro Lap top. In Device manager it appeared as Prolific USB to to Serial Adapter. When I opened Tuner Studio and changed to comm 8 it connected with my controller. Al is good on the Win7 laptop so it looks like the adapter is good.
I tried again on my Win10 PC. The adapter wouldn’t appear at all on Device manager. It looks like I may have some setting wrong or something on my Win 10 PC. Any suggestions?

Is it on Windows 10 where you attempt to run RealDash?

Yes. I believe that Real Dash needs a minimum of Win 10. If it will run on Win7 I could probably use my laptop but I prefer to use the Win10 PC.

RealDash is also available for Android, iOS and Linux.

I believe you need to install the manufacturer specific drivers to your Windows 10 computer in order to use that adapter.

Yes, I agree that is probably the issue with the plugable USB to serial adapter, I am in communications with plugable in that regard. However, my other option is my good old FTDI USB to serial adapter which works just fine on both my Win 10 PC and my Win 7 laptop. It connects to Tuner Studio on both with no problem. I don’t see anything in RealDash to check connections or ports.

As Windows version of RealDash uses Windows Serial port drivers, it ‘should’ work if it works with other apps like TunerStudio. Only thing really that can go wrong there is the baud rate setting in RealDash. With Megasquirt this typically has to be set to 115200.

Thanks to support at plugable I now have both of my USB to serial adapters working on my Win10 PC. Both will connect my controller to Tuner Studio at 115200 baud. Still nothing out of ReaDash. Is there a baud rate setting in RealDash that I can check?

Do I have to buy something to get RealDash to connect? The stores said it was free but maybe I missed something.

Baud rate is selected when you create a new connection for Megasquirt in RealDash. Check your connection settings in the Garage.

Connection settings in garage are “Megasquirt serial/USB,:115200 baud”
Do I have to buy something to connect?


Right then. Why will RealDash not connect to my controller on either my Win 10 PC or my Samsung Tab A tablet when Tuner Studio and Shadow Dash will?

I do not know why. I have Megasquirt here on my desk and it works just fine. If you are sure that baud rate is set correctly, only thing that comes to mind is that you are using a ini file that RealDash is not able to parse. But I understand that you tested without ini file too.