DisplayDash for the VW Golf MK2 Dash

Good day, ladies and gentlemen!

My name is Evgeniy. Born in 1987 in Soviet Russia, living in the Netherlands since 2001.

I finished Bachelor of Automotive Engineering and Master of Automotive Systems.

I was/am a fan of, among other interesting cars, the Golf MK2.

Of course with newer engine and stuff… you know :wink:

So, what is the idea:

  • a 1920x720 10.3" display with the needed display controller
  • RaspberryPi with Lineage OS (Androidy thingy)
  • the green USB-CAN opto-decoupled adapter from AliExpress
  • RealDash as the super nice dashboard app.

The Golf, with which I would try the idea, is equipped with a 1.9 TDI ALH engine, which has CAN-bus output. Now it is the EDC15V, I didn’t check the CAN-traffic yet. On the EDC15VM+, there is CAN-connection to the original instrument cluster, so there must be enough traffic to listen to.

The first step is to get the green CAN-adapter running, and this is where I get stuck. While RealDash seems to recognise it, I can’t see traffic, nor do the LEDs blink continuously. But they blink sometimes.

I have a PCAN-adapter and PCAN-Explorer for the PC to generate traffic for testing :slight_smile:

Does anyone have a suggestion?

Get it! Are you using an analyzer?

Have you found this display? 1920x720 10.3?


Так я подумал - связь нужно устанавливать по CAN. Так как там идёт broadcast данных, а не запрос-ответ как на K-Line.

А так как в RealDash я сразу увидел возможность подключения CAN-адаптера, то такой себе сразу и приобрёл. Зелёный, вот этот:


Мне кажется, CAN - очень удобно… когда работает )))

(For the english speakers: I explain, why I chose to use CAN-Analyzer. It is because I wanted to connect with CAN, as the messages are broadcasted by the ECUs, not like K-Line with KWP2000 “request and receive” and stuff. And RealDash actually lists the green CAN-bus adapter, so I bought it to work with)

Yes, I am already using it.


You need the display and the display driver. It has a HDMI input, which makes it possible to connect with Raspberry.


I installed PC-Software for the green adapter and tested it by sending messages from PCAN.

It works. Apparently, there is a microcontroller in the adapter which is programmable, so there are actually settings possible to be done to the adapter.

It is now set such that I can see what I am sending from PCAN. So, the settings appear to be right.

Still no success in RealDash… It keeps showing “time out”.

Port speed? Right?

На компьютере можно настроить и проверить скорость соединения по серийному каналу и по шине CAN.

По серийному порту советуют 9600 кб/с. Это я установил в RealDash и в настроечной программке адаптера.

По CAN-шине я настроил 250 кб/с. Не медленно и не быстро, на работе тоже с такой скоростью работаем. Это, опять же, настроил в программке адаптера и в RealDash.

С натройками адаптера вроде всё хорошо: подключив его к компьютеру с программой CANtest, я могу видеть сообщения, которые шлю из PCAN.

(The question was whether I have the speeds/data rates set right. The serial port is set to 9600 and the CAN-bus is set to 250. This has proven to work on the PC, so the adapter seems to work.)

A little update:

In PlayStore, I saw an app that can do a serial connection via a CH34x chip, which is inside the green adapter.

It can connect to the adapter. The software seems to only be capable of serial stuff, so I can’t test whether CAN-part of the adapter can be accessed.

For some reason, I think that there is a kind of “permission to access USB” needed… and RealDash doesn’t have it. I already searched for permissions and apps that could give more info, but I don’t see anything that looks like “permission for USB”.

Just to remind about the problem: RealDash tries to connect to the adapter, but fails with a time out…

Please keep it English only. Its better that you who provide text use the translator instead of everybody else.

You are right. I will keep my answers in English :slight_smile:

English no problem! I just wanted to check how much the Russian name is Zhenya)))

Ladies and gentlemen,

I have some progress!

While reading a lot, bit by bit, I remembered this:

With this adapter, always use baud rate of 9600. RealDash connects the adapter in configuration mode (9600 baud), and makes required settings and after that connects again with baud rate of 460800bps. The baud rate of 460800 has been verified to work on Windows and Android versions of RealDash.

And then I was like: wait a second…
I plugged the adapter into RPi, ran RealDash, then connected the adapter to PC and saw in the settings software, that indeed, the baudrate changed to 460800!!
But RealDash itself didn’t change. So then, I changed the settings as well, and now I have a steady RX-LED lighting, while I send some messages from the PC. But it seems to be unstable: I seem to need to do some sequence of actions, as it didn’t work after restart.

I wanted to monitor the traffic, but monitor window was still empty.

Does it only show traffic that is defined in the .xml, or any traffic?

The next step is to understand the CAN-protocol. It seems to differ a lot to what I am used to… I will have a look at the right threads of the forum. But if anyone could point me to the right spot, feel free :slight_smile:

What exactly to point to? Not a completely transparent question!

Hello, can you run realdash on Raspberry?
I tested some systems on it, but couldn’t make it work properly.

Personally, my opinion is that raspberries will not pull RealDash
I recommend Khadas Vim 2 minimum

Good day, ladies and gentlemen!

Long time, no see… Sorry, had plenty of things to do.

I would like to dig up this project and restart digging into the problem.

So, the setup is still:

RPi 3
10,3" screen with controller and HDMI
CAN-USB-II, the green one.

Lineage OS running on the RPi, which, after some love, can run RealDash.

RPi can see the USB-device. It even reacts to it by opening RealDash!

But still, I can’t get it to connect…

I tried to follow the instructions:

  • plug the USB-CAN-II in the PC
  • verify the settings are right >>> 9600 kbaud
  • stick it in the RPi
  • still no succes

I would appreciate suggestions :slight_smile:

Oh, and of course, I will organize a RPi4 with the newest Lineage OS… but I don’t think, that is a problem…

Are you sure that your CAN adapter is exactly the same ‘type 2’ adapter that RealDash supports? I was in understanding that they are no longer available from anywhere.

Good day!

I bought mine here:


It looks like this:

It works with the same software for the PC, that CAN-Test and the settings software.

But… I have a kind of brake-through!!

The RX light is actually flashing! It flashes together with receiving CAN messages I am sending from PC with PCAN.

So, by varying the sending period, I can vary the flash period, which tells me that the stick actually can receive CAN…

… but unfortunately, I still don’t see anything in the CAN monitor.

I did some research and found this:


This guy has a project with RealDash as well, and he can see this:

But my monitor is just empty :frowning:

Okay, so I found my old phone and a USB-OTG-adapter.

I can go as far as that I get well-blinking RX light, while sending messages with PCAN from my pc.

CAN-monitor doesn’t show “timeout” or “not connected”… but neither it shows messages.

Can the monitor show random messages, or do the messages need to be included in the .xml?