Gear indicator jumps to N value

Hi. It seems that this bug is appears after certain update. When real Gear (Body Electronics:Gear targetID) has value other than N, gear indicator jumps from real value to N pretty frequently. So it seems like some kind of flickering.
Regards Ted

Ok, will check.

Have exactly the same issue. Any updates or fixes yet?

For all who have this issue, here is a fix:
Declared the gear data in the XML file as ECU specific Value “MyECU: GEAR”.
Used this Value for the gear indicator on the dashboard.
Done, now readings are stable.
It seems, that if you use the built in gear target id, it conflicts with some internal gear calculations and gets overridden sometimes.

Also, check all input mappings on ‘Settings->Units & Values->Input Mapping’ that there are no conflicting mappings regarding to the gear.

Hi Jani, I am have this same issue from the beginning. My input mapping is Gear is SET FROM Gear (Master speed…ratio). Since I get only inputs from OBD, I only see N when speed is 0 and other gears on the move.

If I set a trigger to show P when speed is 0, it flickers between N and P. How to overcome this?

I don’t have any XML file as mentioned above. I have tried the Neutral safety switch and Reverse lights options but they don’t work.

I don’t think there is an easy solution as Gear (Master speed…ratio) is designed to show ‘N’ instead of ‘P’ at 0 speed.

Maybe the easiest solution would be just add another gauge on top of your gear gauge that shows ‘P’ when speed is 0 and goes invisible when speed increases to show the ‘original’ gear value below it.

Thanks will try this.

In the meantime, I goofed up.

After I sent you this message, I tried to change the input mapping for Reverse lights to Gear (Master speed…ratio) and when I came out of settings menu, Realdash is foreclosing and I am not be open it again.

I tried installed installing your last pre-release (RealDash-v233-prerel7.apk) from your dropbox folder on top of my current version but it says “App not installed”.

How do I get back to opening RD again without losing my data.

Pls help.

Thanks Jani, for helping me solve the App crash issue.

I tried the above. It worked once but today, that gauge is not showing the text P. Even in edit mode (even with static text P) I am not able to see the text P.

I have noticed this vanishing trick for other text gauges too in the past. Is there a limit on the number of gauges per page? I have around 125 gauges in a page.

I tried bring the gauge in front/forward but still doesn’t show up. How to solve this issue?

No, there is no limit. How to solve; impossible to say without investigating your custom dashboard. Unfortunately I just do not have time to do that :frowning: