Help with getting gauges to read can data

Just started to mess with real dash this week.

I am trying to test out several signals to develop a can bus system for dyno testing

I currently using v2 can analyzer and can see my channels both in the CA and real dash program.

I wrote an xml file using the megasquirt xml as a template. I uploaded the xml into real dash. It was for a single frame as a test i assigned traget id 12 for battery voltage to the frame.

I created a simple text gauge in real dash and have assigned every battery referenced input to the gauge and the numbers never come off 0.0

When i stream the can data into real dash i cam see the frame and the data reads correctly from the source signal. I have tried to read as many of the manuals, but can seem to figure out how to comfirn can data being pushed to which input that will output to the gauges in real dash.

1 Like

Here is the test XML for the single battery channel, the can data in RD and the input mapping. I have tried with input mapping, I have tried with can id of 12, and 37 just as a test to give a rpm signal and the gauge stays at 0. I am sure that it is something simple I am looking over once. I can figure it out I can expand it to the rest of the dyno network.

At a quick look it looks correct to me. Try opening the Debug Data View from ‘Settings->Application->Debug’ and inspect if the original ‘MYECU’ value is changing.

Another thing is that maybe your XML is not loaded correctly for any reasong. CAN monitor does not use the XML at all. While in dashboard, you would see ‘Connecting’ tab re-appearing on lower right corner if there is no XML loaded.

I am not having a connection issue, I dont see my ecu in the debug at all. I took a screen recording going the items above. Here is the link for that. I also clicked send debug to developers.

greatly appreciate the help. If I can get this going, it will be an amazing asset for my dyno program and adding in many more datapoints and 3/4d tuning abilities.

I see the problem now, in your XML you have line:

<frame id="0000052a" endianess="little">

When frame ID is in HEX, you need to add 0x to the front of it. Also, little endian is the default, so try to declare your frame like this:

<frame id="0x52a">


Thank you for the quick responses. This opens up alot of stuff.

1 Like