I must be doing something wrong....Serial Can Adapter not working..

I made this digital gauge cluster for my car and for the life of me i can not get it to connect reliably…
Any and all help would be GREATLY appreciated!


Its an odroid c2 running android 6.0.1. I have both a usb bluetooth dongle and the speed studio can adapter 1v7.0.1

The bluetooth obd2 adapter im using is the OBDLink MX+


Originally i tried the simple way of paring with the OBDLink MX+
This proved unreliable as the bluetooth would only SOMETIMES pair, and only after 15 minutes of trying. I also tried this method on a windows PC which works flawlessly, so I assume it has something to do with my android software or the usb bluetooth dongle.

Since the ultimate goal is to use the serial usb can adapter, i decided to spend my time getting that to work…

I have the can adapter connected to the OBD port pins 6 (can high), 14(can low), and 4(ground)
The 120 ohm resistor is installed on the adapter.

The adapter itself is connected to the provided micro usb to standard usb cable and then to an OTG cable plugged into the odroid C2

Ive already downloaded the speed studio software, opened the com port, changed the baud speed, closed and reopened com port set to correct baud rate, and verified that the can adapter flashes 3 times to indicate its set for 115200 baud.

When connected, the adapter IS flashing green indicating that it is actually reading CAN information.

In the realdash software, i do the following

adapters (can/lin)
can analyzer
serial port
select the usb2.0 com port
115200 baud at 500kbps
choose either of the 2 xml files from the Realdash-extras-master file
-channel discription files->realdash can->haltech or holley

the adapter never connects, just times out…

Out of curiosity, I tried to connect to the adapter with other methods in the realdash software…

connections->realdash can->serial->com port->and selected either of the two xml files listed above.

connections->obd2->serial->com port-> and selected the xml file listed under obd2…

Still i cant get the gauges to read.

Any suggestions? i must be missing something simple…

The closest ive gotten to getting CAN infomation was using the last listed method (obd2 over serial). The can monitor displays the following…


Thanks in advance for any help

Seedstudio USB-CAN adapter is connected via:
Adapters (CAN/LIN)->CAN Analyzer->Serial Port->

Please check the correct baud rate per information found in here:

That link says i should be setting both realdash and the adapter to 115200 baud and thats what i have it set to

Is there a different baud rate you suggest i should be using?

On android, will a different baud rate work? Something lower than 115200?

Are both the Haltech and Holley XML files applicable?

Does the can adapter work directly plugged into an android device via usb serial? or am i missing some hardware in between?

I have my usb inputs set to MTP on my odroid device. Is this how i should be communicating with the can adapter?

again, thanks for any help. Ive also tried on a windows 10 pc but to no avail.

First configure the adapter to use 115200 baud rate (use its own windows software). When adapter is powered, adapter shows 3 flashes: Baud rate is 115200.

Then verify the connection with CAN Monitor in RealDash or its own windows software.