"Import File" Problem

Hi,
I am using Android 11 and Realdash v2.0.1 . I cant importing any files.
When I press import it says “please install a file manager”.

I tried different file managers. None of them work.

Es File Explorer w/wo Root Access
Google Files
Total Commander w/wo Root Access
X-plore File Maneger w/wo Root Access

I added a screenshot. When I press import, this opens, but it is not possible to access the home(main) directory. Realdash and all file managers have permissions to access my files.

Is this a bug?
Screenshot_20220103-235836_RealDash.png

I had that issue as well from realdash. What I did was to close realdash and open the file explorer and move the file from my usb drive to the realdash folder and then open realdash and import from it’s own folder.

Thanks for reporting, will take a look.

Even from its own / RealDash folder, it is not possible to import images into the application. Resetting the settings didn’t help.

Android 11.RD 2.0.3 V .
Files are not imported even from the RD root folder.

All rights granted, reset didn’t help, app reinstall didn’t help…
Nevertheless, it is quietly imported on the 7th android.

In which folder should I add all the files that RealDash will work with?
Now I have reviewed and re-read all the recommendations for update 1.9.5 regarding the file system and folder…
Due to poor translation, Google did not attach any importance to them.
But now everything seems to be clear, nothing can be put in the Android / data … folder.
Right?
Then where can you?
Because when I try to import from any folder, I reset to the stock theme.
And there is no internal browser in RD, which, by the way, was also mentioned in update 1.9.5.
Everything is still trying to open through the system file manager…
Any comments?

From Android 11 onwards, apps do not have access to user files on the device unless they have ‘All Files Access’ permission. We tried to add this permission to RealDash, but Google declined this as they feel that accessing files is not ‘Core Functionality’ of our app. There is no fighting with Google.

So, only option is to use external file manager that has all files access. On most Android 11> devices this works just fine, but there are many (escpecially chinese headunits) Android devices that have their own file management systems and even installing another file manager does not override their own crappy ones as they seem to be hard coded.

It’s clear. Machines took over the planet)) At least Cameron guessed first))
And now seriously.
Is this problem only for the version from the play market?
Does the MRD version have these problems?

In this sense, Play store and MRD versions are identical.

I may have found some sort of workaround for this. At least it seems to launch external file manager on some of our test headunits. Will include this hax into next version.

I don’t mean to derale this thread however it is still very much possible to access files outside of the apps internal directory without having to request the permission “All Files Access” or use the legacy method since it will be deprecated fully very soon. I know this because I have my own Android app in the play store that’s able to read and write outside of the apps internal directory. The only permissions used in my app are…

  <uses-permission android:name="android.permission.INTERNET"/>
    <uses-permission android:name="android.permission.BLUETOOTH_ADMIN"/>
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
    <uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>
    <uses-permission android:name="android.permission.BLUETOOTH"/>
    <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>
    <uses-permission android:name="android.permission.WRITE_SETTINGS"/>

To make it possible to access areas outside of the apps internal storage, create a folder in the devices base storage area after requesting the permission WRITE_EXTERNAL_STORAGE. Then create whatever folders you need inside of the folder you created in the base directory of the device. Android will then grant you access to any of the nested folders. The explanation I was given for this was that because it’s a directory that was created by the app it inherits permission to access it.

I have not had any reports from my apps users with issues using this method in Android 11 or 12 as long as the user accepts the request for the permission WRITE_EXTERNAL_STORAGE before you attempt to create the new directory’s and have the app verify this permission is still granted every time the app starts. When an app is not used for an extended period of time and Android removes the apps permissions it can be a little troublesome to get back but I found the best method was to simple “try” to create the folders again. Android won’t overwrite the existing folders or anything in them but it does restore the ability to access them again. Of course if the app is being used regularly then that’s not an issue.

I tested the v2.0.4 on Oneplus Nord and Pixel 5 devices. The problem is solved.
Thanks!

Thanks for testing. It still will not work on all Android devices, but we managed to get some improvement into this situation.

I have been facing the same problem with MI stick tv xiaomi - android 11. When I select the file to import, everything closes and realdash restarts
I’ve tested with several file managers:
Fx
Amaze
drive
same problem…

It is an unfortunate problem that many of these special Android devices override things like file manager handling. Most probable cause for this is a bug in device firmware.

is there another way that can i send this .xml file?

Currently no, only way is to find a file manager that works with that specific device.

We have plans to have XML storage in MRD, so you could upload XML files and easily download them from RealDash. Hope to get this available pretty soon.