INI file on MS3 pro?

Hi All,

I’m fairly new to RealDash and I’ve been using it with my Ecu master black and now I want to hook up to my Megasquirt on my other car. I was able to connect using WIFI, and sending and receiving CAN. However, it does not seem to have the E85 FF content mapped, and I’m guessing I need the INI file that was talked bout in another post… Since there were no instructions anywhere, I’m wondering which INI file I should be pulling off my PC. Also, I don’t see BT connection when I’m searching but I do see it when I connect VIA PC… Is there any reason it wouldn’t show up as an option when scanning through RD?

If you are using CAN connection, there is no need for INI file changes. You can configure the CAN output in Tuner studio to have a custom value to be sent to CAN bus for the Ethanol content.

Then you need to add this new value into Megasquirt CAN XML file that RealDash understands how to read it. You can find the instructions and default Megasquirt CAN files here:

RealDash-extras/RealDash-CAN at master · janimm/RealDash-extras (

Wait, maybe I’m not understanding here. My MS3 Pro has onboard WIFI and BT. This connects to the MS3 via serial. I don’t believe I’m using CAN. However, when I go into RD to select the values for FF Ethanol content, it’s not mapped to what I guess it should be on the MS3. How do I actually map these? There isn’t much online about using the MS3 on RD that’s not very old even on msextra.

Sounds like you are not using CAN connection.

Your default INI file may already contain something like ‘sensor01 - sensor16’, and one of those could contain your Ethanol content sensor reading.

Try the Debug Data View from ‘Settings->Application->Debug’ to inspect all the values that are coming in from your ECU.

Oh, Ok, got it, can you tell me what INI file should be uploaded? There are several INI files.

Search for the ini file that is in your Tuner Studio project folder. Then in RealDash go to the connection settings and import to RealDash.

Ok, I don’t know what file, but I’m assuming it’s the firmware in in the Tunerstuditoms/config/ecudecf location.

I believe the default location is:
Your Documents Folder\TunerStudioProjects\Your Project Name\projectCfg\mainController.ini

Your MS3Pro has wifi/bluetooth?

Yeah I have the perfecttuning ms3 pnp. Has a WiFi and BT module connected to the serial so I don’t need a wire

@realdashdev I did get the file and Flex-fuel still doesn’t show nor does flex fuel temp how would I fix this?

While connected, go to ‘Settings->Application->Debug’ and open the debug data view to see if your FlexFuel data is in any of the ‘Sensor’ inputs from your INI file.

If not, you do have to configure your ECU from TunerStudio to output these into the sensors specified in INI file.

I figured it out; the data for flex fuel is fuel_pct on engine specific. I’m not sure how to map FF ethanol content to that value but I’m guessing you do that behind the scenes

Not really, RealDash just displays the data from Megasquirt as it comes in.

So if your desired value is on ‘fuel_pct’ custom input, make a gauge to your dashboard and link it to this value in order to show it on dash.

Yeah I did.

Just saying that the fed flexfuel is not mapped to the correct value