Intermittent Connection Errors and Can input errors


I’ve been putting this off but decided to finally make a post about it. I’m currently using an aftermarket android double din to run Realdash and am using the Seedstudio adapter for CAN communication with my Link G4X.

There are four issues I come across that I haven’t found out how to resolve yet:

  1. Occasionally (and very randomly) Realdash will lose communication and be stuck in a connecting/timeout loop and never reconnects until the car has been off for an extended amount of time. The adapter is not touched or unplugged from either the ECU or the double din when this happens and it happens randomly while driving or even at startup. Unplugging and plugging it in changes nothing.

  2. I have configured CAN inputs in PCLink and the Realdash xml file. When activated, the CAN switches will turn off at random times. The amount of time they stay on is random; sometimes the switched device is on for minutes at a time, other times it turns off several seconds after I have it switched on.

I am unsure if it is the way I have the dash set up. I tried to configure it so that when I have the switch activated, it is green in realdash but I noticed that when the device shuts off, the switch in realdash is still green. And to turn it off, I have to press the digital button twice.

Ex. Press(button turns green) / press (button turns off) / switched device doesn’t turn off / press (button turns green) / presspress (button turns off) / the switched device turns off

  1. My oil pressure gauge bounces. With key on ignition off, it is at 32 psi. On warm, and cold, idle it will bounce below and back up to 32. While driving the car, it does increase with RPM but still does the bouncing between values. I tried messing with the minimums but nothing changes.

  2. My oil temperature has a similar issue with the exception that with key on ignition off, it sits at 0. With the Key on and the car running, oil temp sits at 32 and then slowly creeps up to operating temperature. I tried doing the same thing as with problem 3 but get the same result.

Any guidance would be appreciated!!

First thing to try is to lower the baud rate of your CAN adapter. If you are running RealDash in relatively slow device, it is very much possible that serial communication is unable to handle all incoming data. When this happens, the serial data will interleave causing invalid data in CAN frames. While RealDash has some error checking for invalid and/or interleaved frames its impossible to make to 100% reliable as the protocol these adapters use do not offer any error checking.

Ok I will try that. I have had issues in the past when trying to change baud rate on the software included with this adapter. I would try to change it by selecting the dropdown menu in “Com bps” after clicking “open”. It would bring out another window specifying baud rate and both values would be different. Sorry if my explanation is a little confusing.

here is a snip of what the main configurator menu:

The only way I was able to get it to work was by leaving it set to the default 2mil Baud rate. Is there a check I can perform to make sure that it is set to the Baud rate I specified?

Hi , I have a Link G4+ which is connected to 2 android devices via CAN with no issues. The attached screenshots shows which settings I am using. What are the specs of your android headunit?
Readash CAN.JPG

Not entirely sure. The android head unit I have is some Chinese off brand one I got off Amazon. I linked the product page for it. Hope this helps. Mine is currently set to the 2mil baud that yours is set to on both pclink and the usb to can adapter.

I also haven’t had the chance to try to change the baud rates yet as I’ve been busy making additions to the car but will test soon.

Podofo Double Din Android Car Stereo Radio with Bluetooth GPS 7 Inch HD Touchscreen in Dash Headunit FM Radio Receiver Support WiFi Dual USB Android iOS Mirror Link with Backup Camera

So I changed the baud rate and it seems to do the sudden disconnection far far less. I guess reducing it further would help with that. The issues with the can buttons randomly turning off on their own and the gauge issues still remain. Does anyone have any advice or guidance they can offer me?

Still having issues with the gauges and buttons. Any advice?

This sort of problems are very difficult to troubleshoot remotely, sorry.

No worries, I understand. I recently updated Realdash and added new buttons instead of repurposing the original ones that were on Data Engineers Dream and it seems to have fixed the button related issues as well as the fixed value issue.

I’m still having the seemingly random connection issues that disappear if I leave the battery disconnected for extended periods of time.

Is there any way to reset realdash so that it can connect?

Closing the app does nothing to fix it. I also tried changing the settings in the communication configuration and then putting them back to what I had originally to see if it would connect but no luck.

Might that still be a baud error?