Lambda gauge does not work

I decided to change the data of the AFR meter in the Virtual Cockpit dash by the data of the Lambda meter, but it does not work, it is parking at 1.

Allrighty, I will check.

The meter works using mapped AFR, but reports a different value. Taking a fixed shaft, when Tuner Studio and the wideband probe conditioner are showing 1.36, Realdash is showing 1.27.

As Speeduino sends AFR only and Lambda is calculated based on stoichiometric setting (fuel type). When its Gasoline, RealDash uses stoichiometric of 14.651 as current gasoline typically contains 10% of ethanol. This may explain the difference in lambda value.

Would you have the option to define the AFR ratio in the garage?

You said that speeduino only sends AFR, but Tuner Studio shows the Lambda value correctly, is it not being sent lambda too?

I think TunerStudio calculates it too but probably uses stoichiometric of 100% gasoline as 14.7, thus the difference.

Could you include the option to set the AFR value manually?

I will take a look of where the UI for that would be.


We can’t figure out a good solution on how to enter a custom value. Instead we added new fuel type as Gasoline E10, which has adjusted AFR for ethanol, and Gasoline which uses stoichiometric of 14.7.

In Brazil we use hydrated ethanol, which has AFR 8.36, which is the value I’m using at Tunerstudio, AFR 9.0 is for anhydrous ethanol. It is not used in Brazil. If you can, add this option of Hydrated Ethanol with AFR of 8.36, thanks.

Ok, will add another type of E100 with stoichiometric AFR of 8.36