MeatPi WiCan issues

Hi everyone,

I am facing an issue while trying to connect my WiCan to realdash, on my 2021 jeep wrangler (manual transmission) i have also tried connecting it to other cars as well and the issue still persists. I followed the exact steps of the video posted on website,
The device i am using is Nothing Phone 2 Android 14 OS.

Settings are:

Mode: AP
AP Channel: 6
CAN Bitrate: 500k
CAN Mode: Normal
Port Type: TCP
TCP/UDP Port: 3333
Protocol: realdash66
MQTT: Disabled

Settings in RealDash (connecting on android device via Bluetooth)

Adapters (CAN/Lin) → RealDash CAN → Bluetooth → WiC_XXXXXX → CAN Monitor

My WiCan is updated to the latest version firmware 2.98 and my hardware version is v3.00_obd

It keeps looping on connecting then shows timeout then back again to connecting.

Anybody has an idea of what to do ?

I had many connectivity issues with this device and specifically I wanted to use Bluetooth so the device (Android) was able to hotspot the internet using the WiFi interface. Try firmware revision 2.10 beta, they compiled this in response to my query and it has been rock solid for Bluetooth connectivity, subsequent revisions (I only tried up to 2.70) did not work reliably.

1 Like