Media Player "Currently Playing" Issue

Hello RealDash community!!

I was messing around the other day with the Media Player options on RealDash in order to make the “Currently playing” inputs (Artist, Title, Album, etc) pull data from a Radio app. I’m currently using VRadio and had some previous experience with other dash apps that would pull data from it so I started with this.

So, first thing I tried was go to Settings → Users → 3rd page and use the “Other” option. The dash prompted me to allow reading notifications (or something like that) which I did and, lo and behold, when I returned to the dash I got all the info I needed. All three default inputs (title, artist and album) showed info, where “Album” was the name of the station.

I was ecstatic that it was so easy to make it work and spent the next hour or so setting up the dash to show bigger texts and fix the placement and the like. Then went on my day.

Here comes my issue (sorry for the long intro, tried to give as much context as possible). Next time I got in the car, I started up the radio, then opened the dash but didn’t got any info on the “Currently Playing” fields I had set up earlier. The only way I could get them to show information was to go back to Settings → Users → 3rd page and select any other option available (apparently, any option works. So far I tried the “Spotify” and “RealDash” options and they both work) for the info to come back.

So, my question is this. Am I doing something wrong? Should I use a different Radio app? Or is there a way to make the field update automatically instead of doing this reset every time??

Thanks in advance.

That sounds like a bug in RealDash, but I did test this multiple times and was unable to reproduce this. I will try a bit more, hopefully I can find this problem.

Wow, fast response!!

I can make a video of the issue if that helps…

I have the same problem … the only way to solve it is to start the player before RD


After some testing on the Weekend, I realised that the above issue only happens on the “Other” option. If I use the “Spotify” option, the fields update normally every time. Since I figured that out, I use that option and it worked flawlessly. I guess the Radio App I’m using uses the same channels to send data as Spotify. Oh well! Guess this issue is fixed! :slight_smile:

On current Android OS versions all those settings basically go to the same code path, which is reading the song info from the music player notifications. That’s why ‘Other’ and ‘Spotify’ works the same. I will still check why ‘Other’ setting does not stay on.

Hi, I am also having some issues with Realdash and spotify… I doesn’t even get the notification “allow reading notifications” when I choose spotify.
I am running a raspberry pi 4 with android 11 OS.

Beside that, Realdash works really well, connected to my Autronic SM4. :grinning:

I tried it on my Samsung S20, and there everything works just fine.

Would be thankful for some tips that might help me.

Jan Hallman

You can find this setting from Android settings. Its called something like “Allow Notification Access” with list of applications to allow for.