Multicast Settings for Host and non-host

So I now have two Ipads that display the way I want them to individually. Now I am trying to get the multicast to function so I can get both of them to display correctly at the same time. I assume that the one for host needs the bluetooth connection and the non-host isn’t connected to bluetooth? And what should the settings be for both ipads n the multicast page and the connections page?

I figured these would be the settings, but the non-host is not receiving anything (the PIDs are exactly the same between both ipads).

Note that both instances must be connected to same local network in order to Data Multicast to work.

You can (and should) disable the ‘Multicast Inputs’ on both instances. This option allows you to multicast touch events from device to another, to act as kind of a remote controller.

Then use ‘Select Multicast Values’ on each instance. Select inputs that you want that instance to send to another. Do not select same inputs on both instances as this will create unnecessary ping-pong of the data between the devices. Simplest way is that one instance is connected to your vehicle and multicasts inputs to another, and another one does not multicast any values.

Lots of questions here.

For when you state “must be connected to the same local network”, are you stating that they must be the exact same HOST IP ADDRESS and PORT, or are you stating that they both need to be connected to the same bluetooth connection (or both)?

So for the Host that is connected to the bluetooth connection, make sure to have the “Multicast Inputs” off, and select all the “values” that I want transmitted from the host ipad to the other ipad.

For the other ipad (non-host), I should not connect it to bluetooth (obviously since you can only have one connection), make sure my “multicast inputs” are off, do not select any “values” as I am only recieving them.

And those setting should give the non-host ipad the information it needs to display information correctly through realdash? Do I need to additionally setup anything special in the ipads setup besides the host bluetooth connection?

These are what I think you mean for the settings to be, but they don’t seem to be working as the host status always just states “Listening connections” and the non-host states “Connecting”. Please advise.

It seems like your iPads are not connected into same Wifi network. Data Multicasting works only via Wifi.

OK, I got this to work as well. Both the Host and the sub ipads need to be connected to the same address of the wifi (for me it was V-Link). And they both need to display the same HOST IP address on the multicast screen. Here are pictures of both for reference

1 Like