Multiple text gauges in 1 place and switch mode

Searched all available info and cant make it…
Task: 6 text gauges are placed in one location, 6 status indicators representing these 6 gauges are also shown, 1st indicator must stay lit after Raeldash start and 1st text gauge must be shown, then button should switch between the rest of text gauges and lit proper indicator…
Was trying with triggers (showing/hiding gauges) but with no success…


To achieve this, you have to use Dummy variable that you rotate with your button, and show/hide actions triggers when Dummy variable changes value.

don’t want to rotate, just make it visible in the same place without any animation

saw how it’s set in the default dashboard, but there are used “next animation” sliders that still don’t know how they work, extra 2 gauges (on the left and right) are hidden under center gauge and they just slide out after clicking on the invisible button area (animation trigger) that uses “next animation” trigger without dummy variable, but “next animation” trigger uses trigger with dummy variable as input, see status indicator but cant see any connections with gauges.

realdashdev can you send a tutorial simple .rd file with 2 text gauge setup placed in the same location and switched by a button?

Perhaps you will suit as an example?
text.rd (2.4 KB)

thanks for that sample and I see a problem, where or how are “Hello” and “Realdash” tabs organized? cant find it, maybe its the bluestacks problem (android emulator)

edit: changed to “static text” and back → reslut: instead of “Hello” and “Realdash” I see 0.0 / 1.0 and 2.0
clicked almost everywhere and cant find these set values

ok, I think I got it, trigger set with dummy 01, actions set with show/hide instructions according to dummy value and it’s working!

Yes. Text sensors work just like that. If you disable static text in the sensor settings, it will show the actual value of the value to which it is connected.

theres a glitch, 5 out of 6 gauges work properly using show/hide actions via trigger, but one doesn’t, when accidentally it’s ok, after reseting realdash it doesn’t appear when pushing a button for 5th step, 1-4 and 6 step works fine but 5th doesn’t, tried many times, making new text gauge too, writting new actions and cant figure out why its happening.
pushing “edit” on 5th state cant see value in the text gauge (on the other states the value is visible because of actions “show”), only see it when selecting gauge source and cant see it in the font selection and properties… is it a kind of glitch? but why in the same place and the same gauge? gauge was copied from working and it does nothing too

Attach an example of what is happening.

sample .rd file with this problem, sometimes dummy 01 at “6” stays on start, is there an action to reset Dummy to zero at start?
multidisplayshowhide.rd (17.3 KB)

[attachment = 0] md_dummy 01 res.rd [/ attachment]

Here is a dummy 1 reset implemented.

This works if you save the panel file with 0 dummy value.
Keep this in mind every time you save a panel.
md_dummy 01 res.rd (19.3 KB)

cool thanks! was testing save at different dummy states with no clue it can be the clue, then set dummy from 1 to 6 instead of 0 to 6, because dont want to click 2x to get change on the screen (from 1st panel to second)

ok, but what about 5th panel at dummy=5? still got it invisible… at you too?

Yes. 5th invisible. I thought it was your idea! Is not it so?
Describe what you should or want to see there?

Just rewrote the sensor. This happens with copy-paste regularly.
I don’t think it’s a lot of work to rewrite a couple of sensors. And you can do the same)))
test2.rd (19.3 KB)

I rewritten the gauge too and it happen again! 5 gauges were a copy of first and only in this 5th gauge is a problem, sometimes the value apprears but only in the source properties…

but I will make 5th gauge again and let you know

thanks for the hint about copy-paste, will remember that :wink:

Joined beta program and upgraded to the last 1.74beta and made 5th gauge, not by copy-paste and it seems to work fine with the rest of extra settings on dummy01.

thanks CoTECH!

Something is still not right… now first gauge is not visible and 5th is visible :slight_smile: nothing has changed, just randomly happened. Sometimes it repairs when going to the garage and go out, sometimes it repairs after restarting the app…

Any sensor behaves the way you configure it. I can’t do anything else … Try to delete this sensor and recreate it. Or try changing the show / hide logic. In any case, experiment.

Something is really messed up deeper in settings than user sees in the app, deleted “hide gauge” action on the start and gauge doesn’t show up after restarting the app, is still hidden

If you see a mistake or a malfunction, write about it in the appropriate section of the forum, you will definitely be answered

Please note that if you save the dashboard and a gauge is hidden, it will remain hidden when dash is loaded.