RealDash not starting after latest update (1.8.8 - fixed)


I have been using RealDash for a couple of weeks, until yesterday everything worked just fine. Today I started the app and it crashed directly during start. It gets to the point were it show the RealDash logo and then it disappears.
It seems like the app updated automatically. I have tried the following things to fix the problem.

  • Cleared app cache, no success
  • Cleared app data, no success
  • Uninstalled the app and reinstalled from play store, no success
  • Complete reset of tablet (android 9.0) only configured WiFi and Play store account
  • Reinstalled RealDash from the play store, no success

I have a similar tablet with RealDash version 1.8.4 and it works like a charm. Auto update is disabled on that Tablet.Is there a way of installing a previous version of RealDash. Are there any settings that may have to be changed for this latest version to work?
I have purchased the full version as well as the Bavarian Powerhouse dashboard.

I am a great fan of your RealDash solution and hope you, me or we can fix this problem. Thanks! Bram

What is Android version on your device? I will keep an eye of Play crash logs and push update quickly if I find this problem.

Android 9.0 kernel version 3.10.72. Thanks!

Would you be able to test quick APK if I build one for you?

Sure, no problem. Just let me know what to do. You could e-mail me if you prefer.

I’ll send you an email. Gimme couple of minutes to make a new build.

I’m having the same issue after the February 1st update when using my custom dash, but it runs fine with the Classic S2000 skin. Is it possible the issue lie in the custom triggers? Happy to share my Rd file if it helps

Please do.

File is too large to attach so I uploaded to Google drive.

Btw I’m running a Samsung Tab S6 LTE SM-T865, running Android 10 Samsung UI 2.5. I was beta tester for app, tried rolling back from beta, still the same issue. Hope this helps! Awesome app! Use it as my main dashboard in my van.

I found the problem on your .rd file. The problem was that your dash file contains another dash file as an image asset. The new, faster dashloader got confused by that and deduced that dash file must be corrupted.

I am going to push a 1.8.8 hotfix very soon. It will be able to load your dash file regardless.

I updated the Google Firebase analytics SDK to the latest version for 1.8.8, and reverting back to older one seemed to fix the startup crash.

Thank you for your help on finding this issue! I will push an quick-fix within couple of hours.

Great! Thank you for your quick replies and working solution.

Ah interesting! I’ll make sure to remove that to from the assets. Thanks!!

New version will not load it so it no longer shows on your image assets. But you may want to go thru your assets anyways as your dash file is very large and probably has unused assets in it.

I’ll definitely give it a scrub. Got the update, it’s working now! Thanks! The only other ongoing issue is Spotify is still finicky to show, but the easy fix has been going in to settings, and switching between Spotify and Google music. Thanks again!!

Could you try with 1.8.9-beta1 if that fixes the issue?

Still the same with 1.8.9 beta. Sorry for my delayed response. Also question, how do you access the assets other then images? Slimming the file down, seeing if that fixes it too.

  • For fonts, select a text gauge and go to ‘Look’n Feel->Font & Text->Select Font’.
  • For video files, select a video gauge and go to ‘Look’n Feel->Video Gauge->Video Source->Select Asset’.
  • For sound effects, only way to access is thru and Edit Action.

I found a problem that if music player is started after the RealDash, the music tracking may not start. This is fixed on 1.8.9-beta2. Don’t know if this has been the reason for music tracking issues you have been experiencing, but its worth a try.