RealDash version 2.3.4

  • 2.3.4 released 19.12.2023


  • New Action: Open Debug Data View.
  • New Action: Back to Previous Page.
  • Multicasting: Album art can be multicasted.
  • Multicasting: Navigation can be multicasted.
  • Experimental OSX version.


  • Fixed crash on input mapping with certain values.
  • Fixed occasional crash on MRD file sync.

You asked for it, so here is an update that is capable of sharing album art and navigation route over the Multicasting. This was technically interesting but at the end of the day not too bad to implement. The image/route data can be tens/hundreds of kilobytes and transferring them over Multicasting must not cause delays on other values. This problem was solved by interleaving very small chunks of data into other Multicasting messages. Still, in bench testing the album art/route typically appears to other devices in less than one second.

To share album art over Multicasting:

  • On the device that ‘actually’ shows the album art, go to ‘Settings->Data Multicast’ and tap ‘Select Multicast Values’
  • Add → Other: Currently Playing Album

To show album art in your dashboards:

  • Create new image gauge
  • Remove any default image from it in ‘Look’n Feel’
  • Link it to Other: Currently Playing Album in ‘Input & Values’

To share navigation route in Multicasting

  • On the device that does the ‘actual’ navigation, go to ‘Settings->Data Multicast’ and tap ‘Select Multicast Values’
  • Add:
    • Device Inputs: Navigation Active
    • You may want to also share Device Inputs: GPS Latitude and Longitude

An experimental OSX version is available for download in My RealDash downloads section. OSX version requires MRD account and credentials to work. The OSX version does not comply with Apple requirements for Store apps as it uses all files access instead of restricted mode. OSX version should be pretty solid, as we have used it internally for years. Please report any problems you may encounter with OSX version.


Love the OSX version as that is what my main programming computer is. With that said , When I maximize or full screen the app it locks up. At first a force close would remedy it but now it attempts to launch in a larger than default window and locks up. I have deleted the app completely, and tried again but still locks up at launch and I have to force close it.

Testing Computer specs:
Ventura 13.6.1
2.3 GHz 8-Core Intel Core i9
AMD Radeon Pro 5500M 4 GB
Intel UHD Graphics 630 1536 MB
16 GB 2667 MHz DDR4

Thanks for reporting, will check.

Edit: OSX 2.3.4-2 now in MRD downloads section.

2.3.4-2. Attempts to open and goes straight to a white full screen with no recovery at all.

The previous version I could delete the info.plist and it would rebuild it and open and work AS LONG AS I didn’t try to resize the window. for now I am using the previous version this way. 2.3.4-2 is not usable at all for me .

EDIT: After further testing … If I remove the info.plist from the contents of the package , then add it to the root of where I have the package ( ie: RD app and the info.plist in the same folder and no plist in the contents of the package) the new version will work as expected.

Interesting, something wrong with the packaging. We did try the package on two macbooks and worked fine :thinking:

No worries. Don’t waste any time on it. The 2.3.4-1 version works with the altered location . It’s fine for right now. Im just using it for an easier design path . I appreciate the OSX version no matter what . :slight_smile:

1 Like

Using the osx version, and when I try to log in it tells me invalid credentials. I am using the same credentials to log into this site though. Any ideas?

The logon in realdash is for My Real Dash subscription, it’s not the same as the forum logon.

Ah - so the credentials I use to log onto my real dash and access this forum are different? I’m not subscribed, but thought those creds would be the same.

This is only true for users that were using this Forum before it was integrated into MRD. Any new user has only one credentials for login.