Serial port issues

Hi Yani,
There are several serial port issue on Android 8.0

When using FTDI , the device shows up on list to select but does not work, the port works find with other apps.

I have spent lots of time ti see what is going on here and my serial ports worked sometimes and not other times.

When using Silicon lab CP2102 ( best in the market ) if it is the first items on the list then it connects and works great, but if it is NOT the first item and it is selected then one will get " Serial device ‘CP2102 USB to UART bridge controller’ is not supported" and it will not connect.

You may ask how to I make it be first item? I do this y just plugging in and out and get lucky and have it be the first item on the list. this works until the Deck goes to sleep and next time may not e the first item and then I get the not supported massage.

unfortunately in this one deck there is always a wifi serial port that I can not remove and it always shows up and most of the time it is the first item on the list,

Thanks for help

Hi Yani,

Do you have any update on this? this is the only thing right now that does not work on my dash. only the CP1202 work great only if it connects.

Also one issue with your realdash can mode is when sending data there is not check sum and any error checking so on uarts errors item in the screen will jump around because of incorrect data, so it will be nice to have some type of validation, I can send video of it if you want.


I did take a look but I was unable to reproduce the problem. I would need to have exactly the same hardware setup as yours to attempt to fix the problem.

Are you using Silicon lab CP2102?

if not I can send you a link to buy one, I would send you one, but shipping costs will be more than you can get one, less than $10 us.

Please let me know.


Yes, send me a link to exact same device as yours and i will buy it for testing.


Thanks so much.

I have tried all type of serial cables, only one that will connects and works reliably is CP2102, but only if first item in serial devices option.

Also I have FTDI cables that the show on list but do not connect at all.

Only one that connects so far is PL2303, but does not work reliably and since there is no check sun for packets items start jumping on the screen. below is link to PL2303 “

Baud rate is 115200, and running at full blast with minimal gaps in data.

Thanks for looking into this, this is the only I have that is no working well, I can also send video if needed.

I can only tell you with the solution to check in the sketch, according to the CAN protocol, when the wrong values ​​come.
You just need to add the conditions via the “if” operator. Then this effect will not be, incorrect data …

This happens when sending data to realdash. data is correct. but since there is no check sun on the packet and if anything lost due to Android driver then bytes will be in wrong place and will cause jump in some date.

Sure. It is for this and the dialogue.

I solved this problem by checking the addresses of incoming frames in the controller code, and only by coincidence did I send to REALDASH. And he achieved a great result.
This solution:

This is the result: if you see interference, throw a brick at me:

“I solved this problem by checking the addresses of incoming frames in the controller code”

Not sure what you mean by controller code? is this on realdash side XML file?
I have two dash one work prefect all the time, ( same data) the other depending on the USB to serial device.

USB to serial should be having any errors, it is just bad driver on Android side.

Frame info is correct most of the time the content is no correct all the time, it is transmitted correctly just no received by RD correctly.

RealDash uses this OpenSource USB-Serial library:

Could this problem in library explain the problems you are experiencing:

No. This is on the side of the arduino.
but which controller do you use?

Got 5 of them from Aliexpress for $1.30 each:

Thanks for working on this, hopefully these are the same and not fake ones.

Thanks for working on this, hopefully these are the same and not fake ones.

Did you check the problem on USB-Serial library I linked above? Is that similar to the problems you are experiencing?

The issue above is on Arduino, I am not using Arduino, I have my own hardware and my own OS.
The issue is only on this dash with Android 8, my side is solid and work with windows and my phone fine and my other dash.

I will get some picture and attach this weekend.


Nonono, its not. Its an Android USB-Serial library that RealDash uses. Please check again.

I did check it, but not good in java script.

I used the same USB to serial on other device and did not see this it it worked weather was in first place or other locations in the list. but his was also Androids 6
The issue may be with this one deck that I have, but really do not know how to solve it. ( this is Androids 8)

will try ti find other USB to Serial.