Speeduino & logging

Hi - I just found that my RealDash (android, 2.1.3) has stopped logging from my Speeduino.
I have a good log recorded on 29 August and first bad log on 10 September, so it may coincide with google play store upgrading me to 2.1.3. Certainly doesn’t align with any Speeduino upgrades I’ve done.

I see you said in other threads that you don’t have speeduino to test - is there any think I can do here? can I down grade my RealDash?



This is a second time I hear about problem with datalogging. I don’t believe its Speeduino related. The previous reporter got it working by re-installing the app, so I don’t have details what might have been the problem. Is uninstall-install an option for you?

Thanks for the reply - I just removed an reinstalled from one of my two devices, but no better unfortunately.
I’ll keep poking around.

I will run all tests related to datalogging too.

I tried to log my daily today, same problem. it creates the log file with field titles, but no data.
Could it be something to do with my user account /profile?

I tried all possible scenarios and found no problems with datalogging. You are surely receiving good data from Speeduino? Try to change the values that are datalogged. Go to ‘Settings->Application->Datalog Format’ and use ‘Select Values’ button to adjust the logged values.

my previous post should have said I was trying to log obd2 on my daily.
I have tried changing the fields logged to just a few basic ones, but still the same problem.
so I have the same problem with obd2 and speeduino.
on two older android devices.
so something to do with my profile or the old android?

Honestly, I do not know whats going on :frowning:


I’ve come across this the same with my MaxxECU race, no datalogging with the ecu. Just a blank file.

If I put RealDash in simulation mode, it data logs fine.

I’ve tried this on my tablet and phone. Both with a clean uninstall/reinstall. I’ve tried it with my custom dash and a few of the premium dashes as well.

I’ve also now tried creating a new google account and buying a new copy of realdash on a new (old) device, same situation. I’m out of ideas!

There is definitely something wrong, but no matter what I try I cannot reproduce this problem on any of my test devices. File access permission issue? I don’t know.

I will use some more time to investigate this.

Thanks for believing me :slight_smile:
if it would help, I can send you one of my devices to test with?


I found the bug. Fix coming soon.

great news.

all working now, thanks again

Thanks for reporting this issue.

Also can confirm its working with my MaxxECU. Thank you dev