Trip log

Hello. Since version 1.8.9, and maybe earlier, when you turn on the log entry, the application crashes. This is on the head device 9 android and the tablet 10android. On the smartphone 6 android works.

Thanks for reporting. I will check the Play store crash logs. Do you have a chance to try the 1.9.1-beta1 from Play store if that still has this problem?

Signed up for the beta test, the issue on 1.9.1 continues.

The app crashes both when you click the button from the quick settings and the button created on the panel

Have you selected the datalog save path in ‘Settings->Application->Data Logging’?

Yes. An empty file is written to the folder. But it works on a smartphone in the demo. I am used the log file to view the house and adjust the panel.

I tested datalogging on all our Android devices, including two with Android 10. Also tried with Android 11 virtual device. I was unable to make it crash, and resulted datalogs seem to be ok. Also, there is no crashes in Play console related to data logging.

Either I do not fully understand what the problem is, or you have some very specific configuration that I’m not able to reproduce.

Thanks for the answer.
Logging works on a smartphone (android 6), there is no problem with recording. On my other devices and on Win 10 with the same configuration, these same actions cause the app to crash and write a file of size 0b.
I can add a video from a tablet (android 10) or win 10, but it will not add information about the problem.

I solved the problem by clearing the garbage from the configuration file in the garage.

The problem with recording the trip log was repeated.
This is my vision.
I make daily changes to the panel, the description file. If you frequently change the panel, the user description file and the parameters recorded in the log, a conflict occurs in the config ( in the section). This causes the app to crash when trying to record the trip log.
Solution remove and replace the config. This leads to the need for almost complete configuration.
I hope I described it clearly, I use a translator.

If possible, send me the line you have in which causes app to crash.

OK, I cleared the last config and reinstalled it. Now it will take time to experiment.

Preferably, send entire settings XML file.

On win10
I can’t insert the files. this is in the demo on win10 without connecting to the car.


So, this ‘Config1.xml’ is the one that causes datalogging to crash?

Based on your settings file, I did find a bug that causes datalogging to crash if datalogging contains ‘ECU Specific’ category inputs that are unknown to the RealDash at that point. Will fix to next release.


Thank you for understanding each other. Probably, if you use a ready-made panel, this bug will be invisible. If you constantly change and test it, sooner or later it appears. Thank you again for your prompt response.