Unable to upload xml to RealDash app android

Evening everyone.

I have been using the app with great success for the past year on a cheap android head unit so I decided to treat myself to an atoto s8 gen2.
I’m in the process of installing RealDash and setting it all up again but I’m having issues with uploading anything from a usb memory stick?

Initially I just tried to upload my current dash file but the RealDash app just showed an empty box when I clicked “load”. I negated this by copy and pasting the dash file into the RealDash app folder via the native file manager app. This then showed as a selectable option in the load box.

Second issue that I can’t overcome is that I need to upload my ECU xml file and the same method doesn’t work for that!

I’m not sure if this is an android issue or a RealDash issue, although I have checked that RealDash has permissions to access usb and storage (which it does)
Also when I start configuring the connection in garage it gives me the option to select “usb serial” or “pen drive” as my source for data and I even unplugged the pen drive and tried again to make sure it wasn’t just a default option and sure enough the pendrive option disappeared so it appears the app itself can see everything attached to the usb’s. It just won’t display what saved on it.

I also checked the can data stream in RealDash and it’s deffinetely seeing my canbus data stream via the canbus/usb analyser.

What I think I’m asking is; Is this a known bug with the latest version of RealDash? (downloaded today from the play store) or is there a setting I need to look at hidden on my headunit?
Or perhaps someone can tell me if they know a way I can manually insert the xml I need somewhere behind the scenes in the apk folder just so it will work?!

Should I uninstall and reinstall? Can I try and install an older version or copy my working version over from the old head unit?

** also if I click “import” in the file selection box android steps in with a pop up saying “no app has permission to do this” - or something similar.

Hopefully some more skilled than me can chime in and help?




I’ve just spent another couple of hour or so trying a few things and I’ve got it to work!

So on a whim I just tried to install the same file browser app as I had in the old unit and then tried clicking “import” again in RealDash and this time it opened the file browser and let me select the xml I wanted!


Hopefully this will be useful for anyone else who has the same or similar problem with an android head unit.


I got caught by this a few times on my Android Audio tablet which occasionally factory resets itself when I start my car!

There was a hidden menu!

Go to Gallery → Load From File → … menu top right next to back button → Settings → Select from Advance devices.

Then it shows me my two USB ports to plug in a USB stick and copy my XML files or new dash files.

1 Like

Been there, dealt with that! My Android Audio tablet loves surprising me with random factory resets, especially when I’m on the road. But guess what? Found a secret hack! Navigate to Gallery, hit ‘Load From File’, then sneak into the menu in the top right corner next to the back button. From there, dive into Settings and choose ‘Select from Advance devices’. Voila! Unveiled my two USB ports, ready to slurp up XML files or new dash files. Crisis averted!