USB Can Analyzer from Seeed

I have been trying to get this to work for a while and I’m now need to ask for help.

I’ve read the topic on how to use this, and anything else I can find. But, the only response I get from the CAN Monitor is:

I’ve checked my wiring twice and that seems ok.
I’ve tried all the options: Can Analyzer, Can Analyzer (type 2), Realdash CAN
I select: Serial USB then USB Serial, 122880 (the device flashes twice), Can speed 500bks, Frame and Extended Frame, The GM - LS descriptor file.

I’ve tried this on my PC, and my long term goal of running the App on a raspberry PI.

I have HPTuners and I can talk to the ECU with that.

The ECU is from a 2012 Camaro, LFX V6

Any suggestions?

First try that you are able to read CAN data with your adapter on its own Windows software. Also, see the instructions regarding its baud rate setting here:

The can analyzer software from Seeed was the first thing I tried. The com baud rate matches the unit. I opened the port and selected Monitor. The ‘bus state’ section shows ''0" for both errors and Error is normal, Bus State is Bus-on. But nothing seems to happen. No data or other indications are displayed. I posted on their forum but haven’t heard a response.

On the Realdash Extra’s page you have two *.md files. Are these two files something I need to use?
The readdash CAN protocol description file indicates you only support 3 frame types. Is it possible that GM uses another type?

Also, I measured the ohms across the 120ohm jumper, and it read 60 ohms, which I believe is correct.

Not sure if this is useful. I have this from the HPTuners VCM Suite information text file:

Protocol Info: ISO 15765-2, J1962: CAN, 500 kb/s

and this…

Scanning Methods: ISO 15031-5 Mode 0x01 Functional, ISO 15031-5 Mode 0x01 Physical, CAN Listener, SAE J2190 Mode 0x22, HPT Mode 0x23, GM Mode 0x2C 0x2D 0xAA

No, those are just text files. You do not need to import any XML to see the data in CAN Monitor.

If you don’t see any data in Adapters own software, there is something wrong with the setup. Very hard to troubleshoot remotely though.