Connectivity issues

Ever since the Dashbox protocol was changed to RealDashCAN 2way, I cannot get a stable connection. It connects for a few seconds, then drops the connection, then connects and drops and so on. Works fine with the old xml file format on version 1.6.2. My dashbox uses a serial connection not bluetooth though.
There is a similar issue if I connect the Link ecu directly, it does show data but I get an error message in bottom left corner that the USB connection is not supported. This problem only exists with version that use RealDashCAN 2way protocol for Dashbox.

Thanks in advance

I do not believe this is related to RealDash CAN protocol. Around that time the Android USB-Serial library that we use was updated and we have heard some complaints with USB connections on Android after that. Seems to happen only on some Android-USB adapter combinations.

Here the same problem…
USB serial connection with windows 10 and Realdash
Older version worked fine!

What is funny:
In the Arduino Example the MAP: value change until 100.00 and the stop.
Serial connection break, reconnect again and then count further…

one more I find out:
In the CAN MONITOR he shows values and after 5 seconds TIMEOUT appears!

170 b3 usb serial problems in RDCan protocol detected. It does not work stably when using several different usb devices(flash,airmouse,ARDUINO). I could not constantly show. Only chaotic. I don’t observe a binding to something. The equipment is the same.
Most likely a serial device conflict.
As always, however.
If I show a malfunction, I can send a log!

Reset the application to default settings, clear the cache, reboot the device. Failures are not observed within 8 hours! Everything is fine! :mrgreen:

On Windows 10:
I reset Realdash, Cache I dont know what you mean…
But still the same fault.

Sorry, I mean Android.

Android have the same problem?
So I guess it is Realdash, not the operating system.

I had similar symptoms, but I cured them!

I have the same problem since today after updating to version 1.7 under Windows 10. After about 5 seconds there is a timeout and then it takes 2 seconds until it works again for the next 5 seconds.
How can I fix this error?
Greetings René

Is there already a solution to the problem?
It’s too bad if the speedometer goes off every five seconds.

Greetings René

What are you connecting to?

I hav the same problem… windows 10 with Arduino over CAN.

There are no problems 171 beta.
The connection is stable.
Arduino nano => RDCan => Android

Unfortunately, this does not help me under Windows 10, there is no beta…

You can still write a trace file (log) and send it to the developer;)

Please try on 1.7.1, as it is now live in Microsoft store.

Hi, I just tested version 1.71. Unfortunately the bug is still there. Now the data is evaluated for about 4 seconds and then the timeout is about 20 seconds until it works again for 4 seconds.

Greetings René