Hello Janimm

I’m very happy with REALDASH and so many thanks to you.

im using on cadillac cts-v

I was using REALDASH with a normal.(ELM USB adapter)
It’s working fine with everything reading well.

So now i moved to
(OBDLINK SX usb adapter ) and I’m very happy with the reading speed

The problem now cannot read everything like a normal usb adapter
obdlink sx not reading Boost & Car Battery voltage.

Did there’s some special setting for OBDLINK SX adapter to read like a normal ELM usb !!


I don’t fully understand your issue. You say that you have exactly the same connection settings as:

OBDLink CAN Adapter->GM->LS Typical

But with other adapter you get some data but not all?

Please give more details of your issue. What data is coming, what is not, what are the OBDLink adapter settings, Do you see the data in CAN Monitor, etc?

my dash setup

  • coolant temperature
  • oil pressure
  • Boost
  • air temp
  • spark advance
  • lambda
  • Battery voltage
    the obd elm327 adapter can read all of those.

so now i changed to obdlink sx adapter and i following
connection settings is

OBDLink CAN Adapter->GM->LS Typical

with OBDLINK SX i get some data but not all
so i didn’t get data for :

  • boost
  • spark advance
  • Battery voltage

So your first setup was with OBD2 connection type? Or was that also as CAN adapter?

1 Like

yes the first(old)
setup is for: ELM327 USB
The source: obd2 - usb - gm ls (typical)
Its reading everything in my dash also
Boost - spark advance - car battery voltage

But now I’m changed to OBDLiNK SX
The setup is:
The source: CAN Analyse - Usb - OBDLINK SX - GM LS (TYPICAL)
It’s working fine and no delay
But it’s not reading Boost - Spark advance - Car Battery voltage

Hello brother .

Any updates please


No, still looking

If Iam not mistaken you can hook your obdlink to a computer, you’ll have download their software to interface with it, but after that then you can change parameters as needed.

1 Like

Hello :wave:
I configured everything with my LS engine with obdlink usb and everything of connection setup is done.
And i like it. Thanks for everything brother.

But i have only one issue with (Oil pressure)
im using at PSI .
The problem it’s not reading correctly
example the reading 42-18-46-28 its like that and very quick reading its not stable.

Watch unnamed | Streamable
please :pray: see the video in this link.


Hello Ahmed,

Could you share the steps and settings that you made to make it read all the parameters needed.


Hello brother Omer …
I’m Using Obdlink SX - USB
The setup is:
The source: CAN Analyse - Usb - OBDLINK SX - GM LS (TYPICAL)

Thanks for the reply, would you kindly share the inputs mapping in the units and value menu since am struggling to get data needed.


it’s depends between what OBD Adapter you are using … if you are using brand name (OBDLINK) with USB its Obdlink SX (red color).
Just follow the steps that I told you
the system automatically recognizes the readings from the BCM… and then you have additional options on what you prefer to read… it depends on your theme settings.
can i know where are u from?
im from :united_arab_emirates: UAE


Am from UAE :united_arab_emirates: too, i still couldn’t figure out how to make it work

start from beginning…

  • Oper the app

  • go to settings

  • open the door

  • click on dash meter

  • click Add

  • choose your OBD Source

  • choose the type of your adapter

  • then click next it’s will showing you the available adapter of OBD

  • then be sure to choose LS typical

  • Done … :ok_hand::blush:

1 Like

Oh okay perfect, it started working

But seems like i couldn’t make the battery voltage to read also the and the MAP sensor too.

You have to customise regarding on what theme you are using

  • clinic on bottom
  • edit
  • add/modify whatever you want
1 Like


hello ahmed ,
I am using the same setup as you are and i tried to connect my ondlink sx cable to the laptop to work on realdash by using the source , adapter (can/lin) → obdlink adapter can → usb/serial → then when i can monitor it just says connecting and stuck on that .
Do you have any suggestions.
I tried it on both my cars

  1. Y61 patrol with ls swap
  2. Y62 patrol stock

Do you have any suggestions.Would really appreciate it.

Typically this scenario happens for two reasons:

  • Wrong baud rate is selected
  • You have not given a permission for RealDash to use your USB device.

When it connects it says that its on 115k buad rate, should i change the buad rate on here or from the setting of the obdlink sx , if so how could i change it and to what baud rate .

Sorry for the extra questions , just trying to get some help and learn . Thanks