Oil Pressure and Temperature Inputs (Link ECU)


I am running a Link G4+ and have made a dash with both Oil Pressure and Temperature, but cannot get them to work correctly.

For pressure, I cannot get it to show the correct pressure value. I am using ENGINE/ECU INPUTS: Engine Oil Pressure and have defined in UNITS & VALUES\INPUT MAPPING making it use Link ECU: AN Volt6 as that is what it is mapped to in the Link. On RealDash it is showing only a 2 digit value (44) whereas the Link is showing a 3 digit value (44XkPa). I have tried using the Multiplier in the Value Properties but nothing changes for me. Is there a way to define what unit the gauge uses?

For temperature, I cannot define Engine Oil Temperature to use the correct mapping as ANTemp 2 is not showing as an option. Is it possible to add ANTemp 1 and 2 to the list of Inputs?

Below is a photo of RealDash running in the car


I see in code that all Link analog input values are divided by 10 before showing. I remember this being a specification for these values. These values should be voltages right? Where is it converted to kPa?

“I see in code that all Link analog input values are divided by 10 before showing.”

So multiplying it by 10 would would show the same value as the ECU?
We did try this and it didn’t work, the multiplier failed to work at all with these inputs

" These values should be voltages right?"

“Where is it converted to kPa?”
They are being converted at the ECU, once the sensor is configured the calculation happens in the ECU so it can use the data, during the picture where it shows 44, I could see it was 440kpa of oil pressure

I’m hesitant to change/remove the ‘divide by 10’ from Link ECU as it probably will mess up the configurations for other Link users.

One thing you can try is to use gauge math to correct the values:

  • In edit mode, select your gauge that is attached to Link analog input
  • Go to Look’n Feel->Special->Gauge Math
  • Enter to gauge math edit box: =V*10


Thanks for that, using the gauge math to correct the values has worked!

Now just need to figure out how to get the temp showing, but I’m guessing that’s link’s issue with the datastream not including ANtemp 1 and 2?


Seems like it, I can’t see ‘ANTemp’ values in either short or long datastream defined by Link.

i’m using vipec ecu, which basically the same as Link, i’m using a custom xml file for the data stream and defined the can data format my self,

i have both oil pressure and oil temperature that work nicely with the realdash. temperature values generally are V-50

the can configuration looks like this from the ECU side
konna_dash.xml (3.86 KB)

1 Like

As for the data stream, there is a table for both the long and short included in the link software, as you can see AN Temp 1 and 2 are on byte 43 and 44

This problem has also been mentioned in the link fourm

And we are using a direct USB connection using serial communication, so changing the CAN stream would do nothing for us unfortunately.

I wonder if Link has changed the datastream as the list you linked differs to the one we got from Link. RealDash reads ECT and IAT from bytes 19 and 21, but to our knowledge GP Temp 1 and 2 are not part of datastreams.

I will contact Link to verify this.

Edit: Could you link me the original source of that list of datastream values?

Unfortunately, this table is from the PCLink G4+ software help file, here is a link https://www.linkecu.com/software-support/pc-link-downloads/

Once downloaded you can go straight to the help tab and then search for datastream and you can see both long and short, im not sure if Link have changed the datastream and havent updated the help file i would say this is very unlikely.

just to reiterate in our setup we have
AnTemp 1 is ECT
AnTemp2 is Oil Temp
AnTemp3 is IAT
AnTemp4 is unused

As the ECT and IAT are on the datastream we dont have a issue with these but as the oil temp is pinned to AnT2 we are unable to configure it in realdash, you just need to make byte 43-44 configable in the inputs menu as 45-46 are already, forgive me if this is not how this works, as ive noticed you can only set these configs while pluged into a link ecu

Indeed, the documentation we got from Link years back, and the information in PCLink app help file differ on some points:

Here are the differences and how RealDash currently interprets the data stream. Differences are the same on short and long data stream:
Byte 25-26: Digital input 1-12 status
Byte 27-28: Wastegate duty cycle
Byte 43: Percentage fuel cut
Byte 44: Percentage ignition cut
Byte 81-82: AFR target
Byte 83-84: Lambda
Byte 85-86: Boost target
Byte 87-88: timer1
Byte 89-90: timer2
Byte 91: Differential fuel pressure
Byte 92: Altitude

I do not know why we have two different information about datastream, but I can make you a test version that changes the bytes 43 and 44 to read ANTemp1 and 2. If you are willing to test, send me an email to contact@realdash.net and I will provide you a download link to test version.

I’ve got confirmation from Link that the stream RealDash currently implements is a old G4 datastream and has been updated on G4+. Their recommendation was to update RealDash to match the current G4+ stream. Fix will be included in version 1.8.0

Thanks for the hard work, interesting that Link changed the data stream from G4 to G4+,
Hopefully, 1.8 works well, I believe starchaser has emailed you so we can try it if you like.

Yes, this fix is confirmed to 1.8.0, which I will get out hopefully during next few days.