Realdash not starting in Windows 10


I have recently downloaded Realdash on my 64bit windows10 pro build 19041.572. Unfortunately when I run the program I momentarily get a black screen for about 200ms and then it drops back into the desktop.

I then proceeded to install Realdash on my Dell XPS15 windows 10 and to my surprise it behaves the same, black screen for about 200ms.

Am I doing something wrong?

Some people have reported this, but we have not found a reason for this. Please try these:

  • Install all available Windows updates
  • Update your graphics adapter drivers
  • Make sure that you have logged in into Microsoft store

We found the problem and are applying the fix to next release (1.8.3).

Meanwhile you can get RealDash started by creating a folder:
‘This PC\Pictures\RealDash\datalogs’

The problem is that in Windows, folder creation is an asynchronous operation. When RealDash starts, it attempts to create this folder and folder is accessed later in code to set the default datalog file folder. In some cases, the folder is not yet created and that causes a crash in app.

Thank you for replying

I have made sure all software and drivers are up to date and logged in correctly to Microsoft store but still no joy.

I will have ago on the laptop again but will be a shame if I cant get it to work, looks amazing software!!!

I realized that it closes when it loses connection to WI-FI.

Yes, I have heard that if you use network drives, like OneDrive to store dash or datalog files, RealDash may hang into black screen when computer goes offline.


I’m having the exact same issue. I’ve upgraded all my drivers and Windows 10 updates and still it won’t run. I’ve even tried it on another PC. I’ve tried it on a laptop and a tablet and it just does the same thing.

Launching the app just blacks out the screen for a moment and then it goes back to the Windows desktop. No error messages or anything.

Yeah, sorry about that :frowning: We test the Windows version on 2 computers and with Surface Pro and have not encountered such a problem. To make matters worse, the Microsoft store crash reports contain only one line, which says ‘Unknown’, so there is no help from there.

Many users have been able to solve this by installing new graphics drivers, especially on laptops with Intel graphics chipsets.


Well I’ve spent most of the day updating and ensuring that everything has been updated but it hasn’t made any difference. :cry: :cry: :cry:

Is it possible to roll back the version in the store or get an earlier version to see if that works?

Microsoft store does not offer such functionality.

Hello to all :slight_smile:

I have same problem.
I tested it in two computers with updated drivers and system.
One laptop is with intel i3 with integrated intel graphics and second is lenovo intel I5 with gtx1650 graphics.
Same effect. After run realdash program installed from microsoft store display momentary go all black and after less that 1 secont in back to windows desktop. thats all.

I try solved that proble with microsoft win 10 problem resolving tool and got that information (not sute it is for that problem):

Naprawa: Błąd systemu Windows „NET HELPMSG 2182
so it means: Fixing: Error Windows „NET HELPMSG 2182.

No another problems with both computers (except running realdash) and all another programs run and install without any problems…

best wishes

It’s not very impressive is it. The current MS Store version just seems to be a dud.

This is a real shame as I have already bought a 14.9" display and LVDS driver to install permanently in my car. :cry:

I understand that this is annoying. We can see from the Microsoft store console that there has been 37 crashes with reason ‘Unknown’, and during the same period of time there has been thousands successful sessions. So its not 100% broken. As the crash happens before the intro, we suspect that it has something to do with initialization the connection with Microsoft store.

One more thing that you could try is to install Microsoft Visual Studio 2019 redistributable from here:

Maybe some computers do not have all libraries installed required by Visual Studio 2019 apps.

One more thing you could try:

Hi All,

An update on my experiments trying to get Realdash working on Windows 10.

I have update all drivers and window files, cleared out MS store cache and installed Microsoft Visual Studio 2019 redistributable but nothing works… I have also tried to carrying out the same on my desktop and that also does not work…

However a glimmer of hope is I installed a Windows10 VM on my laptop and to my surprise Realdash runs although a bit slow as to be expected… the only difference I could see is the Win10 VM does not use the Nvida graphics driver.

Disabling the Nvida driver under normal Windows10 disappointingly did not resolve Readash.

I hope someone else has better luck than me.



I did the suggested actions above and it didn’t make any difference.

I went onto my tablet and just did the wsreset and then RealDash ran! And then it also ran on the other computer despite not having done so about 15 minutes earlier.

I’d like to think that the changes that I tried fixed it but I suspect the App was changed.

Still a result though. :smiley: :smiley: :smiley:

Well done, seems to me it could be an external issue somewhere with MS store, maybe you have reset something but unfortunately for me its still the same problem.

We have not updated the Windows version since 15th of October. We are currently in communication with Microsoft to solve this issue.

Sorry to hear it’s still not working for you. :cry:

I made all above and add visual studio library, all without succes…
glad to hear you try solve problem :slight_smile:

Hi Realdashdev

Not sure its relevant, I have been doing so more experimenting and with my laptop disconnected from the internet and noticed that the Windows10 VM machine that works usual halts on the white screen with the red “NAPKO” presumably because of no internet access.

where as the normal windows only fleetingly shows a black screen and then drops back to the windows desktop as if nothing happened. on this evidence not sure its a MS store issue or not?

Cheers and thanks