VSS in Speeduino and Realdash

Speeduino updated the firmware and added a VSS signal input, it would be nice to be able to use this VSS signal in Realdash through Speeduino, I already installed it on the digital pin and configured it in Tunner Studio, it recognizes the speed of the car in Tunner Studio, but nothing appears on the Realdash. Thank you.

Allrighty, I will check.

Could you try and verify the VSS and Lambda fix for Speeduino on 1.7.6-BETA3?

I tested on Windows 10 and Android 7 and 10. On Windows 10, after adding the connection in the garage, I went to the Virtual Cockpit, went to edit, selected the speedometer, and then selected which data entry, when searching for VSS, appear 3 options, VSS1, VSS2 and speeduino vss (km / h), I selected speeduino, and it worked perfectly on Windows 10, already on android 7 and 10, when doing all this procedure, in the search only 2 options appear, VSS1 and VSS2. Speeduino vss (km / h) does not appear. The lambda worked when I selected it.


Other information, on windows 10, I used the usb connection, on android 7, I used bluetooth 4.0 HM-10 on the khadas board, on android 10, I used bluetooth 4.0 HM-10 on Xiaomi Mi 9 Lite.

There is no Beta for Windows 10 (only for Android) so fixes are not available there :frowning:

I understand, but on my notebook running windows 10, the speedometer worked, I selected in INPUT & VALUES: SPEEDUINO: VSS (KM/H), but on my cell phone and on the khadas plate running android the SPEEDUINO: VSS (km/h) does not appear, using the same speeduino.ini in all cases, and uninstalled and installed the app again to check if there was something previously saved that wouldn’t let it work. It only appears in search ENGINE/ECU INPUTS:VSS1 and VSS2. It finds this information (speeduino: vss (km / h)) from the speeduino.ini file

In SETTINGS> UNITS & VALUES> IMPORT VALUES, Speeduino: vss (km / h), is there in windows 10, but in androi it is not, it does not appear. I don’t know if there is a way to import this data manually, informing the ini file again.

Yes, its there on ECU Specific list as Windows 10 does not have the VSS fix yet. The current Android BETA maps the incoming Speeduino VSS directly to ECU VSS input and therefore it no longer appears in ECU specific list.

To map it directly allows the VSS to work on all existing dashboards without any special mapping.

Thanks, works now.

I realized that the speed (vss) through the Serial0 connection works, through Serial3 it doesn’t work.

Ok, I will take a look.

Hi realdashdev , on the Speeduino vss input . I can’t get speed to read . I tried going to engine/ecu input tried
Vss1,vss2, vehicle speed but none work for me so I have no speed Odo .
My problem is am using a android headunit but for some reason it will not let me loaded any of my 4 purchased Dash am stuck with a custom 1 I created neither can I load any files so I can’t load any ‘ini file’
So my only option is using the
(November 2019 firmware default)
But VSS is not in the list can you update the default please?
Thanks Garcia

I got VSS working on realdash through Serial3. Again this is what I have to do because I can’t load any files to realdash.

So in Speeduino folder find file :

Scroll down to the packet list and change one of 15auxin “canin” to use as you VSS input port. I used canin[5] as canin 0-4 is already been used fuel fuel, R signal ,L signal, Oil press, P brakes

fullStatus[51] = lowByte(current status.canin[5];

fullStatus[52] = highByte(current status.canin[5

Change it to:

fullStatus[51] = lowByte(current status.vss);

fullStatus[52] = highByte(current status.vss);

Save file and

save a copy of your project & tune first.
then reflash firmware to Speeduino.

In realdash: ecu specifics
(Speeduino: auxin5 ) for you VSS input

That’s it speed should now work on serial3

Great, thank you for troubleshooting this :thumbs:

Awesome app :+1: works flawlessly as a full time dashboard in my car
Thanks for supporting Speeduino community